SP 2.0 Control Panel -- SSL Certificate Issuing
Incident Report for StackPath
Resolved
This incident has been resolved.
Posted Nov 20, 2020 - 18:16 UTC
Monitoring
A fix has been deployed and Stackpath Engineers have confirmed the impact is resolved. Users should once again be able to request and provision new free SSL certificates in the SP 2.0 platform.

We are continuing to monitor the situation.
Posted Nov 20, 2020 - 17:32 UTC
Investigating
Stackpath is currently investigating an issue with new SSL certificates on the SP 2.0 platform.
Our engineers are working to resolve this matter with further updates to follow as they become available.

If you have questions, our Support team is available 24/7 through email at hi@stackpath.com or phone at +1 (323) 313-1206.
Posted Nov 20, 2020 - 17:04 UTC
This incident affected: Systems (SSL).