SSL issues
Incident Report for StackPath
Resolved
All remaining SSL certificates have been restored and a fix has been implemented.
Posted Jun 10, 2020 - 12:40 UTC
Update
Our engineers have implemented a fix that should ensure all new requests for FreeSSL will go through. Meanwhile we have managed to restore one part of failed SSL requests that were made since 17:00 UTC yesterday, up until 9:00 today. We'll continue work on restoring all remaining certificates, and provide another update once the second phase is complete.
Posted Jun 09, 2020 - 19:26 UTC
Update
Stackpath engineers are still trying to resolve the issue with our SSL provider. We will post new updates as soon as one becomes available.
Posted Jun 09, 2020 - 07:09 UTC
Identified
We have identified the issue to be related to our SSL provider. We are continuing to work with our SSL provider to deploy a fix.
Posted Jun 09, 2020 - 03:46 UTC
Investigating
Stackpath is currently experiencing issues with assigning new SSL certificate. Currently issued SSL certificates on the platform are working as expected. Our engineers are working to resolve this matter with further updates to follow as they become available.

If you have questions, our Support team is available 24/7 through email at hi@stackpath.com or phone at 1-800-570-2253.
Posted Jun 08, 2020 - 22:57 UTC
This incident affected: Systems (control.stackpath.com).