Phone Support Service Disruption
Incident Report for StackPath SecureCDN
Resolved
Issue has been fixed, all calls are again operational.
Posted 20 days ago. Feb 02, 2018 - 21:21 UTC
Investigating
Our telephony provider is currently experiencing a power outage with one of their providers that might cause issues with incoming calls. If you need to speak with support urgently, please submit a ticket, provide your direct call number, and we will call you as soon as possible. Thank you in advance for your patience.
Posted 20 days ago. Feb 02, 2018 - 19:46 UTC