Issues with new sign ups and viewing/changing billing details
Incident Report for StackPath SecureCDN
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 11, 2018 - 19:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Jan 11, 2018 - 19:40 UTC
Investigating
We are experiencing issues with our Billing provider, new sign ups might be delayed and viewing/changing billing details for existing customers will not be possible until fix is implemented. Our engineers are looking into this issue, we will keep you updated.

If you have any questions, our Support team is available 24/7 through live chat and ticketing at https://app.stackpath.com/support
Posted 5 months ago. Jan 11, 2018 - 19:09 UTC